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1. Installation Notes 

1.1 Server/Workflow Version 

The use of "DOCUMENTS Workflow" version 1.2 or later requires a server 

environment version "ELC 3.50"/"otrisPORTAL 5.0" or higher. 

"DOCUMENTS Workflow" version 1.3/1.3.4 or higher requires a server version 

"ELC 3.51" or otrisPORTAL 5.1. Alternately, a server version "ELC 3.60a" can be 

used. 

For server version "ELC 3.60c"/"otrisPORTAL 6.0c" or higher, you have to use 

"DOCUMENTS Workflow" version 1.3.5 or higher. 

Workflows which have been designed and created using Documents Workflow 

1.3.5 have to be converted to use them with Documents Workflow Version 2.0. 

Once converted into the version 2.0 format, the workflow can’t be edited in 

earlier versions of Documents Workflow. 

Converted 2.0-workflows can be exported into ELC 3.60c or otrisPORTAL 6.0c. 

Features that aren’t supported by ELC 3.60c or otrisPORTAL 6.0c will not be a 

part of this export. 

For server version "DOCUMENTS4", you have to use "DOCUMENTS Workflow" 

version 2.0. 

1.2 Microsoft® Visio® Version 

The COM add-in can be used for the products Microsoft® Visio® 2002, Visio® 

2003, Visio® 2007 or Visio® 2010. When using Visio® 2007, the installation must 

be carried out with "DOCUMENTS Workflow" version 1.3.4 or higher. The same 

applies to Visio® 2010. UTF-8 support in "DOCUMENTS Workflow 2.0" requires 

Visio® 2003 or later.  
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2. Installation 

Please carry out installation using the Setup program included. In doing so, all files 

are stored in the selected installation directory. The installation must be carried 

out by a user with administrator rights. 

The "Program Files-> Documents->Documents Workflow" directory will be used 

for the recommended typical installation. Regardless of the selected installation 

directory, you will find the "Documents-> Workflow" entry on the "All Programs" 

menu. 

If after the installation you engage in activities via administrator or power user 

rights on the system, all necessary steps have already been completed through 

installation, and you can immediately use the application via the "Visio Document 

Template". 

If you are working on the system only as a "user" with restricted access or as 
"domain user", you will have to start the "Initial startup" link prior to initial 
startup. 

An entry is set in the Windows registry through this file which enables Visio to use 

the "WorkflowSet.dll" file. You confirm the prompt asking whether the 

information should be added to the registry by clicking "Yes". You can then use 

the application via the "Visio Document Template". (For alternatives and more 

detailed explanations, see section "COM add-in link" [see Figure 1]). 

 

Figure 1: Links on the program menu created by the installation 

2.1 File paths for stencils and solutions 

In order for Visio® to retrieve the "WorkflowSet.vss" stencil and the 

"WorkflowSet.vst" document template, you should integrate the installation 

directory into the Visio paths. To do this, for Visio® version 2002, choose the 

"Tools->Options" menu item, and then the "File Paths" tab. In the text fields for 

"Templates" and "Stencils", enter the path to the installation directory with a 

leading semicolon. 



DOCUMENTS-Workflow Installation  6 

On Visio® 2003 and Visio® 2007 you will find the file path settings under "Tools-

>Options->Advanced". The corresponding dialog appears on clicking the "File 

Paths" button (Figure 2).  

Please be aware that Visio saves these settings individually for each user. 

 

Figure 2: Advanced file paths for stencils and templates in Visio 2003 

In Visio® 2010 you will find the file path settings under "File->Options->Advanced" 

in the "General" section“ (Figure 3). 

 

Figure 3: File locations for Visio 2010 

You should really make this setting if you want to edit other users' workflows 
or replace these. 

Because the Visio® drawings contain a reference to the original stencil location 

and the stencil has sometimes been installed to a different directory, Visio® might 

not be able to retrieve the stencil. Whereas these settings enable Visio® to 

retrieve the "WorkflowSet.vss" stencil and to open it together with the 

drawing. 

You can also directly open the stencil in Visio® and thus link a drawing sheet to a 

stencil (Figure 4): 
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Figure 4: Open stencil for an existing drawing sheet in Visio 2002 

The following settings should be automatically set for a Visio standard installation 

and for correct operation of the "DOCUMENTS Workflow" installation. They are 

listed here just for completeness, and should be consulted in case of problems. 

This particularly applies in case no dialog opens on double-clicking any shapes of 

the "DOCUMENTS Workflow". 

2.2 Security settings 

To enable Visio® to access the COM add-in, check whether access has actually 

been enabled in Visio® or whether this is locked for security reasons. To do this, 

on the main menu, open the "Tools" menu item, and then the "Options" subitem 

(Figure 5). 

 

Figure 5: Tools->Options menu 
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In the Options dialog, choose the "Security" tab (Visio®2002). In Visio®2003 you 

choose the "Security" tab (Figure 6). 

 

Figure 6: Security settings in Visio 2003 

Verify that the checkboxes of the "Enable COM add-ins" and "Enable Automation 

events" are checked, and enable these by clicking, as necessary.  Changes that 

have been made will only take effect on restarting Visio. 

Visio®2007 requires that the "automation events" be enabled. This setting can be 

made on the "Advanced" tab in the Options dialog (Figure 7). 
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Figure 7: Enabling automation events on Visio 2007 

Visio®2010 also requires that the "automation events" be enabled. This setting 

can be made in the "General" section in the Options dialog (File->Advanced, see 

Figure 8). 

 

Figure 8: Enabling automation events on Visio 210 
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2.3 COM add-in link 

When initially starting the document template "WorkflowSet.vst", this must 

be linked to the "WorkflowSet.dll" file as the responsible COM add-in installed on 

your system. You need to perform this process once only; for administrators and 

power users of the system, this should have already been performed with the 

installation. This assignment ensures that an entry is in fact set in the Windows 

registry. 

If, however, you engage in activities on the system as "user" with restricted 

access, this assignment must be subsequently performed because you do not 

have the required rights to be able to carry out installations and make changes to 

the system. 

There are basically three options for this. 

Using the created links, execute the "Initial startup" link, and then confirm the 

prompt asking whether the information should be added to the registry by 

clicking "Yes". 

Double-click on the registry file "WorkflowVisio.reg" in the installation 

directory, and confirm the prompt asking whether the information should be 

added to the registry by clicking "Yes". 

Run the "regedit" program via "Start->Run", and import the 

"WorkflowVisio.reg" file via the "File->Import" menu item. 

Use the registry editor "regedit" to directly create the entry: 

[HKEY_CURRENT_USER\Software\Microsoft\Visio\Add-Ins\WorkflowSet.Connect] 

"FriendlyName"="WorkflowSetAdd-In" 

"Description"="Visio-COM-Add-In for workflow-design and automatic workflow-

generation" 

"LoadBehavior"=dword:00000003 

"CommandLineSafe"=dword:00000000 

This process can alternately be performed manually in Visio. To do this, however, 

you will then need administrator or power user rights on the system: 
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2.3.1 Microsoft® Visio® 2002 and Visio® 2003 

To do this, under Visio 2002 and Visio 2003, on the main menu, choose the 

"Tools" menu item, and then the "Macros" subitem with the "COM Add-Ins" entry  

(Figure 9). 

 

Figure 9: Tools->Macros->COM Add-Ins 

The COM add-ins dialog now allows linking the document with the add-in. If the 

"WorkflowSet add-in" has not yet been entered under "Add-Ins available", press 

the "Add" button (Figure 10). 

 

Figure 10: Details dialog "Com Add-Ins" 

The file selection dialog "Add Add-In" now lets you navigate to the 

"WorkflowSet.dll" file stored in your installation directory (Figure 11). Default: 

"Program Files -> Documents -> Workflow -> WorkflowSet.dll". 

After you select the "WorkflowSet.dll" file you must click "OK" to close the 

dialog. If the "WorkflowSet.dll" file is then not displayed in the details dialog 

"Com Add-Ins", the Visio assignment cannot have been executed. The reasons for 

this usually are insufficient permissions on the system. In this case, create the 

relationship as described above (see 1-4). 
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Figure 11: File selection dialog "Add Add-In" 

These changes will also only take effect after restarting Visio. But you can deny 

the Visio prompt asking whether you want to save the drawing, and exit Visio 

without saving. 

2.3.2 Microsoft® Visio® 2007 

On Visio 2007 the "WorkflowSet Add-In" should be displayed as an active add-in. 

The information on this can be found under Tools->Trust Center->Add-Ins (Figure 

12). 

 

Figure 12: Add-Ins management in Trust Center on Visio 2007 
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Should the add-in not be listed as either "active" or "inactive" add-in, you can add 

it to the add-ins by clicking the "Go" button in the dialog's bottom section and 

navigating to the "WorkflowSet.dll" file that has been stored in your 

installation directory using "Add".   Default: "Program Files -> Documents 

-> Workflow -> WorkflowSet.dll". After you select the 

"WorkflowSet.dll" file you must click "OK" to close the dialog. 

 

These changes will also only take effect after restarting Visio. But you can deny 

the Visio prompt asking whether you want to save the drawing, and exit Visio 

without saving (Figure 13). 

 

Figure 13: Add-Ins management on Visio 2010 – File->Options-Add 
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3. Compatibility with various versions 

Because the "WorkflowSet.dll" file and "DOCUMENTS Workflow" are subject 

to on-going development, we must preclude that shapes, for example, which stem 

from a newer version with advanced functionality scope are stored in a drawing 

that is then processed by an "old" DLL file. These "newer" shapes might contain 

information that earlier program versions simply cannot process and that 

therefore imperil the server functionality, which is why in such cases an update 

warning – specifying the affected shapes – is output, and the application is also 

disabled, if necessary.  

If the application has been disabled, you should check prior to re-opening 

workflows in Visio whether the "Automation events" setting [see above] is 

enabled. 

The current version number of the "WorkflowSet.dll" file is also displayed in 

the Workflow dialog's headline. 

Moreover, version 1.2 or higher checks the server version determining whether 

the server supports the functionality required from the Visio add-in. You can run 

"DOCUMENTS Workflow" on server versions "ELC 3.50"/"otrisPORTAL5.0" or 

higher.  

You can run versions 1.3 and 1.3.4. with server versions "ELC 3.51"/"otrisPortal 

5.1" or higher. 

You can runversion 1.3.5 with server versions "ELC 3.60c"/"otrisPortal 6.0c" or 

higher. 

You can run version 2.0 with server versions "DOCUMENTS 4" or higher. 

You can run version 2.0 with server versions ELC 3.60c or otrisPORTAL 6.0c.  

Workflows which have been designed and created using Documents Workflow 

1.3.5 have to be converted to use them with Documents Workflow Version 2.0. 

Once converted into the version 2.0 format, the workflow can’t be edited in 

earlier versions of Documents Workflow. 

Converted 2.0-workflows can be exported into ELC 3.60c or otrisPORTAL 6.0c. 

Features that aren’t supported by ELC 3.60c or otrisPORTAL 6.0c will not be a 

part of this export. 
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